Official Packages

RSS Feed
doxygen 1.8.15-1 x86_64
vlc 3.0.6-1 x86_64
libplacebo 1.7.0-1 x86_64
wpscan 1:3.4.3-1 x86_64
dav1d 0.1.0-1 x86_64
x11vnc 1:0.9.16-1 x86_64
metasploit 5.0.0-1 x86_64
python-scapy 2.4.2-1 any
scapy 2.4.2-1 any
python2-scapy 2.4.2-1 any

Update your mirrorlist

  • 近期文章
  • 文章归档
  • 功能




  • 欢迎来到 Arch Linux 中文社区

    Arch Linux是一个轻量的、灵活的Linux发行版,遵循K.I.S.S.原则。

    目前我们有专门为x86_64架构优化的官方软件包。作为官方软件包的补充,我们还有一个社区维护的,数量和质量每天都在增长和进步的软件源

    我们强大的社区热情而乐于助人,同时我们以能够用自己的技术能力使用Arch并作为Arch的主干力量而自豪。请查阅我们的论坛邮件列表来加入我们。如果你想了解更多关于Arch的信息,可以看一看我们的Wiki

    Learn more...

    RSS Feed

    最新文章

    astyle>=3.1-2 更新需要手动干预

    2019 年 9 月 2 日

    astyle 包在 3.1-2 之前的版本缺少了一个动态库的链接。这个问题已经在 3.1-2 中修复,所以更新过程需要覆盖掉 ldconfig 创建出的未被 pacman 跟踪的链接文件。如果你在更新时遇到如下报错:

    astyle: /usr/lib/libastyle.so.3 exists in filesystem

    那么请使用如下命令

    pacman -Suy --overwrite usr/lib/libastyle.so.3

    来完成系统更新。

    tensorflow>=1.14.0-5 更新需要手动干预

    2019 年 8 月 21 日

    tensorflow 包在 1.14.0-5 之前的版本缺少几个动态库的链接。这个问题已经在 1.14.0-5 中修复,所以更新过程需要覆盖掉 ldconfig 创建出的未被 pacman 跟踪的链接文件。如果你在更新时遇到如下报错

    tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
    tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
    tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem
    

    那么请使用如下命令

    pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1
    

    来完成系统更新。

    libbloom>=1.6-2 更新需要手动干预

    2019 年 7 月 11 日

    libbloom 包在 1.6-2 之前的版本缺少了一个动态库的链接。这个问题已经在 1.6-2 中修复, 所以更新过程需要覆盖掉 ldconfig 创建出的未被跟踪的链接文件。如果你在更新时遇到这样的报错:

    
    libbloom: /usr/lib/libbloom.so.1 exists in filesystem
    

    请通过:

    
    pacman -Suy --overwrite usr/lib/libbloom.so.1
    

    来完成更新

    mariadb 10.4.x 更新需要手动干预

    2019 年 6 月 30 日

    遵从上游的建议, mariadb 更新到 10.4.6-1 或者之后的版本需要改变配置文件的布局。
    主配置文件的位置从 /etc/mysql/my.cnf (以及它的引入文件夹 /etc/mysql/my.cnf.d/ )移动到了 /etc/my.cnf (相应的 /etc/my.cnf.d/ )。请确保迁移您的配置。

    逐实例的服务(像 mariadb@foo.service 这种)不再用单独的文件配置(像 /etc/mysql/myfoo.cnf 这种),而是移动到了主配置文件中的带群组后缀的配置块里面,每个服务一个带后缀的配置块。一个配置块看起来类似这样:

    
    [mysqld.foo]
    datadir = /var/lib/mysql-foo
    socket = /run/mysqld/mysqld-foo.sock
    

    和之前几次 mariadb 功能性升级一样的是,这一次也需要升级 data 文件夹。在修改好配置文件之后请运行以下命令进行升级:

    
    systemctl restart mariadb.service && mariadb-upgrade -u root -p
    

    libutf8proc>=2.1.1-3 更新需要手动干预

    2018 年 7 月 15 日

    libutf8proc 在 2.1.1-3 之前的版本中含有错误的 soname 链接,我们在 2.1.1-3 版本中修复了这个问题,因此更新时需要手动覆盖掉 ldconfig 创建出的未被跟踪的文件。如果你看到如下错误:
    libutf8proc: 文件系统中已存在 /usr/lib/libutf8proc.so.2
    请执行:
    pacman -Suy --overwrite usr/lib/libutf8proc.so.2
    之后继续更新系统。

    js52 52.7.3-2 更新需要手动干预

    2018 年 5 月 5 日

    由于 /usr/lib/libmozjs-52.so 的 SONAME 不符合其文件名, ldconfig 创建了未管理的文件 /usr/lib/libmozjs-52.so.0 。现在已经修正这一问题,两个文件都包含在新包中。

    为防止更新报错,请于更新前删除 /usr/lib/libmozjs-52.so.0

    glibc 2.27-2 和 pam 1.3.0-2 升级或需手动干预

    2018 年 4 月 20 日

    glibc 最新版本删除了 NIS 和 NIS+ 的相关支持。在 filesystem 包中默认的 /etc/nsswitch.conf 文件已经根据这一变化做了相应修改。请在升级前确认是否存在 pacnew 文件,并确保已经合并了其中的变更。

    如果需要 NIS 功能,仍然能通过安装 libnss_nis 包提供该功能。不过对于 NIS+ 目前官方源中没有替代方案。

    同时 pam 1.3.0-2 包不再提供 pam_unix2 模块以及 pam_unix_*.so 兼容性符号链接。请在升级前仔细检查 /etc/pam.d 文件夹中的 PAM 配置,用 pam_unix.so 替换掉以上被删除的模块。使用 pam_unix2 的用户还需要在修改 PAM 配置之后重置他们的密码。 pambase 包提供的默认配置不需要额外修正。

    zita-resampler 1.6.0-1 -> 2 升级需要用户手动干预

    2018 年 2 月 23 日

    zita-resampler 包的 1.6.0-1 版本在打包时缺失了一个库文件的符号链接,我们已经在 1.6.0-2 中加入了这个文件。如果您安装过 1.6.0-1 ,那么 ldconfig 将会在安装时创建这个链接,从而它会和 1.6.0-2 打包中的链接文件形成文件冲突。如果 pacman 提示文件冲突,请手动删除 /usr/lib/libzita-resampler.so.1 ,然后继续正常升级。

    停止支持 i686 架构

    2017 年 11 月 8 日

    随着9个月的逐步抛弃阶段结束,今日起我们正式停止对 i686 架构的支持。我们将于11月底从软件源服务器删除 i686 包,随后也将删除归档服务器上的包。

    对于无法将硬件升级至 x86_64 架构的用户,我们建议他们使用 Arch Linux 32 作为替代,这是由社区维护的下游发行版。具体的迁移步骤请参考他们的网站。

    Perl 库路径变更

    2017 年 9 月 3 日

    现在开始 perl 包将会在编译模块的路径中添加版本号。这意味着针对不同版本的 perl 编译的模块将不会被加载,进而需要重新编译。

    在升级的时候会有一个 pacman hook 对受影响的模块提出警告,类似这样:


    WARNING: '/usr/lib/perl5/vendor_perl' contains data from at least 143 packages which will NOT be used by the installed perl interpreter.
    -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'

    使用这些模块之前你必须重新编译他们。这一变动同样会影响到通过 CPAN 安装的模块。并且在下一次 Perl 的大版本更新时,比如更新到 5.28 或者 5.30 时将需要再次重新编译。

    请注意早在此次变更之前 perl 已经要求重新编译模块了,然而从此之后 perl 将不再尝试载入那些模块并且会以奇怪的方式失败。

    如果某些软件的构建系统不能找到正确的路径,你可以在 PKGBUILD 中使用 perl -V:vendorarch 来查询正确的路径。同样还有 sitearch 用于那些并非由 pacman 打包管理的软件。

    Older Posts »


    © 2012 Arch Linux Chinese Community | Arch Linux 中文社区
    GNU FDL 1.3
    Original designed by Archlinux.org · XHTML · CSS · RSS
    Proudly powered by WordPress | Server by RivenCloud
    The Arch Linux name and logo are recognized trademarks by Judd Vinet & Aaron Griffin. Some rights reserved.