Official Packages

RSS Feed
libmpdclient 2.11-1 i686
beignet 1.3.1-1 x86_64
embree 2.15.0-1 x86_64
aarch64-linux-gnu-gcc 6.3.1-1 x86_64
aarch64-linux-gnu-gcc 6.3.1-1 i686
git 2.12.2-1 x86_64
git 2.12.2-1 i686
python-ipywidgets 6.0.0-1 any
python2-ipywidgets 6.0.0-1 any
jupyter-widgetsnbextension 1:2.0.0-1 any

Update your mirrorlist

  • 近期文章
  • 文章归档
  • 功能




  • 欢迎来到 Arch Linux 中文社区

    Arch Linux是一个轻量的、灵活的Linux发行版,遵循K.I.S.S原则。

    目前我们有专门为i686和x86_64架构优化的官方软件包。作为官方软件包的补充,我们还有一个社区维护的,数量和质量每天都在增长和进步的软件源

    我们强大的社区热情而乐于助人,同时我们以能够用自己的技术能力使用Arch并作为Arch的主干力量而自豪。请查阅我们的论坛邮件列表来加入我们。如果你想了解更多关于Arch的信息,可以看一看我们的Wiki

    Learn more...

    RSS Feed

    最新文章

    今日更新的 fcitx(-gtk2) 在 gtk2 应用中无法使用问题的解决与启示

    2012 年 11 月 19 日

    今日更新了 fcitx, 许多用户反馈在部分应用程序中无法激活/使用, 虽然这类问题已经并不新鲜, 但是我觉得还是有必要说明一下.

    首先, 这个问题从根本上是 pacman 的错(升级顺序混乱).

    升级的时候你应该看到 fcitx-gtk2/fcitx-gtk3 的 installing 后面跟着个 error, 那就是因为, 存在下面的依赖链(以 fcitx-gtk2 为例):

    fcitx-gtk2 -> gtk2 -> pango -> harfbuzz -> icu

    最后的两个都在升级列表里, 而按照逻辑, fcitx-gtk2 需要在他们之后升级才是正常的, 但是 pacman 没有考虑这个问题(依赖链中间有两个未参与此次升级的包).

    我今天中午收到反馈就 bump 了版本(在基友 yuyichao 的建议下更新了 fcitx-gtk2.install, 简单的 hack 了一下使得以后类似情况时不出现此问题), 现在你看到(或者装了)的应该是 -3 结尾的版本号. 但是即使升级后, 所有使用 gtk2 相关库的应用程序仍需重启才能生效.

    因为类似情况并不是第一次出现了(以前有数次大规模 rebuild 后某些包不正常的情况), 基本上如果你在升级过程中看到有库链接错误/segfault/参数错误之类的提示, 在此次升级指令完成后把这些出错的包重新安装, 如果还有错, 继续安装有错的包直到没有错为止. 这样基本上可以解决大部分的此类问题.

    另附此次我机子上 fcitx-gtk* 升级出错的 log 以便大家参考前文的分析 (无关包已去掉)

    [2012-11-17 10:58] upgraded icu (49.1.2-2 -> 50.1-2)
    [2012-11-17 10:58] upgraded fcitx (4.2.6.1-1 -> 4.2.6.1-2)
    [2012-11-17 10:58] usr/bin/gtk-query-immodules-2.0: error while loading shared libraries: libicule.so.49: cannot open shared object file: No such file or directory
    [2012-11-17 10:58] upgraded fcitx-gtk2 (4.2.6.1-1 -> 4.2.6.1-2)
    [2012-11-17 10:58] usr/bin/gtk-query-immodules-3.0: error while loading shared libraries: libicule.so.49: cannot open shared object file: No such file or directory
    [2012-11-17 10:58] upgraded fcitx-gtk3 (4.2.6.1-1 -> 4.2.6.1-2)
    [2012-11-17 10:58] upgraded qt (4.8.3-5 -> 4.8.3-6)
    [2012-11-17 10:58] upgraded fcitx-qt (4.2.6.1-1 -> 4.2.6.1-2)
    [2012-11-17 10:58] upgraded harfbuzz (0.9.5-1 -> 0.9.5-2)

    请用户重新加入社区交流群

    2012 年 11 月 9 日

    由于服务器磁盘用尽,我们的群程序在执行存储时崩溃,部分好友信息丢失,当前我们的管理员正在重建社区交流群。IRC频道不受影响。

    根据当前工作进度,请丢失好友关系的用户在明天早晨9点之后重新加入本群: talk@archlinuxcn.org

    GNOME 3.6 升级须知

    2012 年 11 月 8 日

    ibus-1.4.99不稳定版发布,新功能包括 GNOME 3 的集成。Arch官方维护者为了实现该新功能,并没有将相关编译选项关闭,此举导致大量 GNOME 3.6 + ibus 用户的输入法框架崩溃。

    社区会员经过与Arch官方的讨论(https://bugs.archlinux.org/task/32071),官方开发者仍不愿关闭该编译选项。因此社区建议 GNOME 3 用户考虑以下2种方案。

    • 对于愿意尝试新鲜环境的用户,切换到其他桌面环境/窗口管理器 KDE/XFCE/LXDE等桌面环境和Openbox/fluxbox/Enlightenment等窗口管理器都是非常好的选择,并且这些桌面环境/窗口管理器为用户提供了更友好的计算机桌面操作体验和更多可调节的空间。
    • 对于希望继续使用 GNOME 3 的用户 保留 GNOME 3 并切换到其他输入法框架 由 Arch Linux TU Felixonmars 维护的 libibus (aur/libibus, archlinuxcn/libibus) 为 GNOME 3 用户提供了这个可能。添加 Arch Linux 中文社区源 (repo.archlinuxcn.org) 或直接通过 AUR 即可安装。如遇提示 ibus 冲突,选择[Y]替换ibus,安装完成重新登录即可通过原本的方法(设置环境变量等)切换到其他输入法框架(例如 Fcitx)。

    11月发布的安装介质已经可以下载

    2012 年 11 月 3 日

    最新的安装和救援盘已在我们的下载页面提供下载。2012.11.01 的 ISO 镜像和前一版相比主要包含了少数 bug 修复,清理和新的软件包:

    • Linux 3.6 的第一张介质
    • 在网络引导时,copytoram = n 可以用于避免将镜像复制到内存。这可能是不可靠的,但在内存很低的的系统中的也是个解决办法。
    • cowfile_size 启动参数,主要用于 VFAT 的持久 COW (写时拷贝)。详细信息请参阅 README 文件。

    bug 消灭日:11月17日星期六

    2012 年 11 月 2 日

    Allan McRae 写道:

    Arch Linux 的 bug 跟踪系统中的 bug 数量正在攀升,是时候将它们干掉了。

    这是社区参与和帮助 Arch Linux 团队的好方法。过程很简单。首先在 bug 跟踪系统中找到你喜欢的软件的一个 bug,并检查它是否仍然会发生。如果是,请到上游项目找补丁并测试它以确认它是否被解决。如果没有补丁,请确保这个 bug 已经提交给了上游的 bug 跟踪系统。

    加入我们的 IRC 频道 #archlinux-bugs。我们的人遍布各时区,所以应该随时都有人在。



    © 2012 Arch Linux Chinese Community | Arch Linux 中文社区
    GNU FDL 1.3
    Original designed by Archlinux.org · XHTML · CSS · RSS
    Proudly powered by WordPress | Server by VPSTO
    The Arch Linux name and logo are recognized trademarks by Judd Vinet & Aaron Griffin. Some rights reserved.